Injection timing on OM 603

The G Spot

New Member
Joined
Aug 14, 2021
Messages
12
Age
56
Location
Machadodorp
HI team please help me. I rebuilt an OM603 . When I set the pump timing to 15 degrees ATDC the engine smokes white . As a test I set the timing to TDC.It starts beautifully and no smoke . I retarded it on the adjustment until it ran smooth but had an injector knock , it ran much better but ran hot uphill Have you guys experienced this before ?
 

Alan

G-Wagen Club SA
Joined
Oct 12, 2008
Messages
3,889
Age
58
Location
Pretoria
Was the pump worked on and by who?
I had a similar problem after the pump was worked on. I eventually had to remove th pump to get more adjustment. I adjusted it until it ran smooth and without smoke. Have not had any issues since. 60kkm.
 

The G Spot

New Member
Joined
Aug 14, 2021
Messages
12
Age
56
Location
Machadodorp
Hi Allan . Yes and no . I bought a recon pump from Rolf at TW diesel that kept on smoking white . Then I bought another out of a running vehicle and it did the same until I totally advanced it . The timing marks on the engine are spot on and cam timing is also right ?
As a test I fitted the pump to another engine and it has the same symptoms.

Am I going crazy or is there a mechanical explanation .

Regards Lou
 

Alan

G-Wagen Club SA
Joined
Oct 12, 2008
Messages
3,889
Age
58
Location
Pretoria
I know what you are going through and eventually accepted that the pump was not pit together correctly internally.
 

Pete460332

Staff member
G-Wagen Club SA
Joined
Oct 8, 2008
Messages
2,942
Location
Cape Town
Did you follow the factory manual ? The method is to line up the IP with special tool and then check the mark on pully
 

Pete460332

Staff member
G-Wagen Club SA
Joined
Oct 8, 2008
Messages
2,942
Location
Cape Town
Ok, maybe have to revert to drip method but there is no spec for that - if you have a working one you could measure its driping point
 

The G Spot

New Member
Joined
Aug 14, 2021
Messages
12
Age
56
Location
Machadodorp
Thank you Pete.

I am going to try that.

Regards Lou
 

Attachments

  • 20210823_172835.jpg
    20210823_172835.jpg
    354.2 KB · Views: 22

Pete460332

Staff member
G-Wagen Club SA
Joined
Oct 8, 2008
Messages
2,942
Location
Cape Town
So that will be 24 BTDC? keen to hear how it goes . How difficulty is it to take out the delivery valves without upsetting the calibration
 

Alan

G-Wagen Club SA
Joined
Oct 12, 2008
Messages
3,889
Age
58
Location
Pretoria
So that will be 24 BTDC? keen to hear how it goes . How difficulty is it to take out the delivery valves without upsetting the calibration
Don't think you can. When I replaced the O-rings on the injector pump they stress not to use magnetic screwdriver or tools. If you pull the valve/piston out you have to calibrate pump again.
 

Pete460332

Staff member
G-Wagen Club SA
Joined
Oct 8, 2008
Messages
2,942
Location
Cape Town
Thats a problem then as you need to remove delivery values I suspect ( if the same as OM617 ) to do the drip measurement. There must be another method then - I seem to recall using compressed air ?
 

Alan

G-Wagen Club SA
Joined
Oct 12, 2008
Messages
3,889
Age
58
Location
Pretoria
I think you just remove the line from the injector.
Andrew Hall has done it I think, maybe he will chime is when he next visits here.
 

The G Spot

New Member
Joined
Aug 14, 2021
Messages
12
Age
56
Location
Machadodorp
Good morning . I reset the pump timing at 7 degrees ATDC .
The engine started easy and no white smoke and no excessive injector knock .
I still have to roadtest but I think we nailed it .
Thank you for all your comments .

Regards Lou
 

The G Spot

New Member
Joined
Aug 14, 2021
Messages
12
Age
56
Location
Machadodorp
Morning Alan .
Thank you very much . That must have happened to both my pumps .
We are never to old to learn .

Regards Lou
 
Top